SearchSearch   ProfileProfile   Log inLog in   RegisterRegister 

12045 or 12157 (firstspot_gw_srv_[timestamp].log) at startup

 
Post new topic   Reply to topic    FirstSpot Forum Index -> Announcement, Technical FAQ
View previous topic :: View next topic  
Author Message
alan
Forum facilitator


Joined: 26 Sep 2003
Posts: 4362

PostPosted: Thu Jun 14, 2012 6:03 am    
Post subject: 12045 or 12157 (firstspot_gw_srv_[timestamp].log) at startup

You encounter 12045 or 12157 error (see WinINet error code at http://msdn.microsoft.com/en-us/library/aa385465.aspx) within firstspot_gw_srv_[timestamp].log under FirstSpot\log directory during FirstSpot startup (which will trigger "reduced functionality mode" error in the Configuration Manager -> Status). The reason for this error is that the CA is not trusted by Windows (12045) or SSL libraries error (12157). Most likely you will meet the following conditions:

1) You are paid customer
2) This problem only starts to happen in year 2012 (12045) or the end of 2014 (12157)
3) You are using the older Windows XP or 2003
4) Your Windows are out-of-date on the SP level
5) You haven't use the FirstSpot machine's IE to surf the Internet for a while

The solution for the above problem is to trigger a root certificate update for your Windows machine. Please try below one-by-one (in exact order):

1) Use IE to browse:

https://patronsoft.com/firstspot/
https://www.firstspot.info/ssltest/

and make sure the SSL cert is okay. Try to trust the CA manually if necessary

You might need to install hotfix 968730 if you have difficulties viewing these two sites in https. Also, make sure you select TLS 1.0 under Internet options -> Advanced -> Security and install IE8.

2) Make sure your SP level is up-to-date

3) Make sure "Update Root Certificates" Windows components is installed (Windows XP or 2003 only)
_________________
~ Patronsoft Limited ~
Back to top
alan
Forum facilitator


Joined: 26 Sep 2003
Posts: 4362

PostPosted: Mon Oct 17, 2016 9:38 am    
Post subject:

Note that we don't support Windows XP/2003 in the v8.1.x anymore. Please upgrade your Windows and FirstSpot as soon as possible.
_________________
~ Patronsoft Limited ~
Back to top
Display posts from previous:   
Post new topic   Reply to topic    FirstSpot Forum Index -> Announcement, Technical FAQ All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group